SDK Platform release notes | Android Developers

This page provides liberation information about the SDK packages available for download from the SDK Manager, in the SDK Platforms check .

Each SDK Platform adaptation includes the following packages :

  • The Android SDK Platform package. This is required to compile your
    app for that version.
  • Several System Image packages. At least one of these is required
    to run that version on the Android
    Emulator.
    Each platform version includes a system trope for each defend mannequin divisor ( handsets, Android television receiver, and Android Wear ). Each imprint factor may offer variations to match your computer ‘s processor computer architecture ( such as Intel x86 and ARM EABI ). System images labeled Google APIs include entree to Google Play services and those labeled Google Play besides include Google Play Store.

  • The Sources for Android package. This includes the source files for
    the platform. Android Studio may show lines of code from these files while
    you debug your app.

The revision numbers listed below are for the Android SDK Platform package only. The system images may receive offprint updates, normally to resolve bugs with the copycat. There are no release notes for the system images, but you should constantly keep them up to date .
Important: To see the most late Android arrangement components in the Android SDK Manager, you must first update SDK Tools to the most recent release and restart the SDK Manager .

Android 13 (Beta)

For details about the platform changes, see the Android 13 preview documentation .

Android 12 (API levels 31, 32)

12L feature drop (API level 32)
For details about the platform changes, see the 12L
documentation.
Android 12 (API level 31)
For details about the platform changes, see the Android 12
documentation.
Android 12 ATD system images
This Automated Test Device ( ATD ) visualize is an android system double that is optimized for brainless automatize tests. early data indicates that tests that use this image should experience decrease in copycat process CPU and memory use, and reduction in trial wall time .
It achieves these performance gains through :

  • Removing most user-facing applications (for example Dialer, Settings, and
    SystemUI).
  • Disabling hardware renderer drawing.

The effigy comes with two versions : Google APIs ATD which provides Google APIs, and AOSP ATD which provides pure AOSP experience .
To learn more about running tests using ATDs, see Run tests using Automated Test Devices .

Android 11 (API level 30)

For details about the platform changes, see the Android 11 documentation .

Android 10 (API level 29)

For details about the platform changes, see android 10 for Developers .

Revision 5 (July 2020)

This revision adds Android Automotive OS stub .

Android 9 (API level 28)

For details about the platform changes, see android 9 for developers .

Revision 1 (August 2018)

Released to stable channel ( no longer in preview ) .

Android 8.1 (API level 27)

For details about the platform changes, see android 8.1 for developers .

Revision 1 (December 2017)

Released to stable channel ( no longer in preview ) .

Android 8.0 (API level 26)

For details about the platform changes, see android 8.0 for developers .

Revision 2 (August 2017)

Released to stable channel ( no longer in preview ) .

Android 7.1 (API level 25)

For details about the platform changes, see android 7.1 for developers .

Revision 3 (December 2016)

incremental update. Released as the final Android 7.1.1 ( no longer in preview ) .
Dependencies :

  • Android SDK Platform-Tools 25.0.1 or higher is required.
  • Android SDK Build-Tools 25.0.1 or higher is required.

Revision 2 (November 2016)

incremental update. Released as Android 7.1.1 Developer Preview 2. For more information, see the Android 7.1 API Overview .
Dependencies :

  • Android SDK Platform-Tools 25.0.1 or higher is required.
  • Android SDK Build-Tools 25.0.1 or higher is required.

Revision 1 (October 2016)

initial spill for Android 7.1 ( API level 25 ). Released as Android 7.1 Developer Preview 1. For more information, see the Android 7.1 API Overview .
Dependencies :

  • Android SDK Platform-Tools 25.0.0 or higher is required.
  • Android SDK Build-Tools 25.0.0 or higher is required.

Android 7.0 (API level 24)

For details about the platform changes, see android 7.0 for developers .

Revision 1 (August 2016)

initial release for Android 7.0 ( API level 24 ). For more data, see the Android 7.0 API Overview .
Dependencies :

  • Android SDK Platform-tools r24 or higher is required.
  • Android SDK Tools 24.0.0 or higher is required.

Android 6.0 (API level 23)

For details about the platform changes, see the Android 6.0 changes and Android 6.0 APIs .

Revision 2 (November 2015)

Fixed bugs in the layout rendering library used by Android Studio .
Dependencies :

  • Android SDK Platform-tools r23 or higher is required.
  • Android SDK Tools 24.3.4 or higher is required.

Revision 1 (August 2015)

initial release for Android 6.0 ( API level 23 ). For more information, see the Android 6.0 API Overview .
Dependencies :

  • Android SDK Platform-tools r23 or higher is required.
  • Android SDK Tools 24.3.4 or higher is required.

Android 5.1 (API level 22)

For details about the platform changes, see the Lollipop overview and Android 5.1 API changes .

Revision 1 (March 2015)

initial publish for Android 5.1 ( API tied 22 ). For more information, see the Android 5.1 API Overview .
Dependencies :

  • Android SDK Platform-tools r22 or higher is required.
  • Android SDK Tools 23.0.5 or higher is required.

Android 5.0 (API level 21)

For details about the platform changes, see the Lollipop overview and Android 5.0 API changes .

Revision 2 (December 2014)

Updated layouts in the Support Library and fixed versatile issues .
Dependencies :

  • Android SDK Platform-tools r21 or higher is required.
  • Android SDK Tools 23.0.5 or higher is required.

Revision 1 (October 2014)

initial liberation for Android 5.0 ( API degree 21 ). For more data, see the Android 5.0 API Overview .
Dependencies :

  • Android SDK Platform-tools r21 or higher is required.
  • Android SDK Tools 23.0.5 or higher is required.

Android 4.4W (API level 20)

This version makes KitKat available for Android Wear .

Revision 2 (October 2014)

Updated the rendering library .
Dependencies :

  • Android SDK Platform-tools r20 or higher is required.
  • Android SDK Tools 23.0 or higher is required.

Revision 1 (June 2014)

initial spill for Android Wear .
Dependencies :

  • Android SDK Platform-tools r20 or higher is required.
  • Android SDK Tools 23.0 or higher is required.

Android 4.4 (API level 19)

For details about the platform changes, see the KitKat overview and Android 4.4 API changes .

Revision 2 (December 2013)

sustenance turn. The system interpretation is 4.4.2. For more information, see the Android 4.4 API Overview .

Dependencies:
Android SDK Platform-tools r19 or higher is required.
Android SDK Tools 22.3 or higher is recommended.

Revision 1 (October 2013)

initial dismissal. The organization version is 4.4. For more information, see the Android 4.4 API Overview .

Dependencies:
Android SDK Platform-tools r19 or higher is required.
Android SDK Tools 22.3 or higher is recommended.

Android 4.3 (API level 18)

For details about the platform changes, see the Jelly Bean overview and Android 4.3 API changes .

Revision 2 (August 2013)

care update. The system adaptation is 4.3 .

Dependencies:
Android SDK Platform-tools r18 or higher is required.
Android SDK Tools 22.0.4 or higher is recommended.

Revision 1 (July 2013)

initial liberation. The system adaptation is 4.3 .

Dependencies:
Android SDK Platform-tools r18 or higher is required.
Android SDK Tools 22.0.4 or higher is recommended.

Android 4.2 (API level 17)

For details about the platform changes, see the Jelly Bean overview and Android 4.2 API changes .

Revision 2 (February 2013)

maintenance update. The system version is 4.2.2 .

Dependencies:
SDK Tools r21 or higher is required.

Revision 1 (November 2012)

initial spill. The system adaptation is 4.2 .

Dependencies:
SDK Tools r20 or higher is required.

Android 4.1 (API level 16)

For details about the platform changes, see the Jelly Bean overview and Android 4.1 API changes .

Revision 3 (October 2012)

maintenance update. The system interpretation is 4.1.2 .

Dependencies:
SDK Tools r20 or higher is required.

Revision 2 (July 2012)

alimony update. The system adaptation is 4.1.1 .

Dependencies:
SDK Tools r20 or higher is required.

Revision 1 (June 2012)

initial spill. The organization version is 4.1.0 .

Dependencies:
SDK Tools r20 or higher is required.

Android 4.0.3 (API level 15)

Revision 3 (March 2012)

sustenance update. The system adaptation is 4.0.4 .
Note: This system image includes support for copycat hardware graphics acceleration when used with SDK Tools r17 or higher. ( more information )

Dependencies:
SDK Tools r17 or higher is required.

Revision 2 (January 2012)

care update. The system version is 4.0.3 .

Dependencies:
SDK Tools r14 or higher is required.

Revision 1 (December 2011)

initial secrete. The system version is 4.0.3 .

Dependencies:
SDK Tools r14 or higher is required.

Android 4.0 (API level 14)

Android 4.0, Revision 2 (December 2011)

maintenance update. The system interpretation is 4.0.2 .

Dependencies:
SDK Tools r14 or higher is required.

Android 4.0, Revision 1 (October 2011)

initial turn. The system version is 4.0.1 .

Dependencies:
SDK Tools r14 or higher is required.

Android 3.2 (API level 13)

Android 3.2, Revision 1 (July 2011)

Initial release. SDK Tools r12 or higher is recommended.

Android 3.1 (API level 12)

Android 3.1, Revision 3 (July 2011)

Dependencies:
Requires SDK Tools r12 or higher .
Notes:
Improvements to the chopine ‘s rendering library to support the ocular layout editor program in the ADT Eclipse plugin. This revision allows for more draft features in ADT and fix several bugs in the previous give library. It besides unlocks several editor program features that were added in ADT 12 .

Android 3.1, Revision 2 (May 2011)

Dependencies:
Requires SDK Tools r11 or higher .
Notes:
Fixes an issue with the ocular layout editor rendering library that prevented Android 3.1 from running in ADT .

Android 3.1, Revision 1 (May 2011)

Dependencies:
Requires SDK Tools r11 or higher .

Android 3.0 (API level 11)

Android 3.0, Revision 2 (July 2011)

Dependencies:
Requires SDK Tools r12 or higher .
Notes:
Improvements to the chopine ‘s rendering library to support the ocular layout editor in the ADT Eclipse plugin. This revision allows for more draw features in ADT and repair several bugs in the previous supply library. It besides unlocks respective editor features that were added in ADT 12 .

Android 3.0, Revision 1 (February 2011)

Dependencies:
Requires SDK Tools r10 or higher .

Android 2.3.3 (API level 10)

Android 2.3.3, Revision 2 (July 2011)

Dependencies:
Requires SDK Tools r12 or higher .
Notes:
Improvements to the platform ‘s rendering library to support the ocular layout editor in the ADT Eclipse plugin. This rewrite allows for more draw features in ADT and specify several bugs in the previous render library. It besides unlocks several editor features that were added in ADT 12.

Android 2.3.3, Revision 1 (February 2011)

Dependencies:
Requires SDK Tools r9 or higher .

Android 2.3 (API level 9)

Android 2.3, Revision 1 (December 2010)

Dependencies:
Requires SDK Tools r8 or higher .

Leave a Reply

Your email address will not be published.